# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^0-9.,]//gm;t' <<< "(626.123*) 34a2- 4387,222222)"