use strict;
my $str = '(626.123*) 34a2- 4387,222222)';
my $regex = qr/[^0-9.,]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";