import Foundation
let pattern = ##"(\b(?'first_word'[A-Z](?!([A-Z0-9]*\b|[[:alnum:]]*_)(?# the word isn't in all caps and doesn't contain underscores))(?:[a-z0-9]*)))|(\G(?'trailing_word'[A-Z][a-z0-9]*))"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
PascalCase
Pascal
PascalCaseCase
Pascal684Case
Pas45calCase
PascalCase6523Case
PascalCaseCaseCase
PPascal
PascalCCase
camelCase
// some random commentary with Capitalized and SCREAMING letters
SCREAMING_SNAKE_CASE
Pascal_Snake_Case
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\L${first_word}${trailing_word:+_\L${trailing_word}:}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)