import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b(?'first_word'[A-Z](?!([A-Z0-9]*\\b|[[:alnum:]]*_)(?# the word isn't in all caps and doesn't contain underscores))(?:[a-z0-9]*)))|(\\G(?'trailing_word'[A-Z][a-z0-9]*))";
final String string = "PascalCase\n"
+ "Pascal \n"
+ "PascalCaseCase\n"
+ "Pascal684Case\n"
+ "Pas45calCase\n"
+ "PascalCase6523Case\n"
+ "PascalCaseCaseCase\n"
+ "PPascal\n"
+ "PascalCCase\n"
+ "camelCase\n"
+ "// some random commentary with Capitalized and SCREAMING letters\n"
+ "SCREAMING_SNAKE_CASE\n"
+ "Pascal_Snake_Case\n";
final String subst = "\\L${first_word}${trailing_word:+_\\L${trailing_word}:}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}