use strict;
my $str = 'PascalCase
Pascal
PascalCaseCase
Pascal684Case
Pas45calCase
PascalCase6523Case
PascalCaseCaseCase
PPascal
PascalCCase
camelCase
// some random commentary with Capitalized and SCREAMING letters
SCREAMING_SNAKE_CASE
Pascal_Snake_Case
';
my $regex = qr/(\b(?'first_word'[A-Z](?!([A-Z0-9]*\b|[[:alnum:]]*_)(?# the word isn't in all caps and doesn't contain underscores))(?:[a-z0-9]*)))|(\G(?'trailing_word'[A-Z][a-z0-9]*))/mp;
my $subst = '\\L${first_word}${trailing_word:+_\\L${trailing_word}:}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";