$re = '/(\b(?\'first_word\'[A-Z](?!([A-Z0-9]*\b|[[:alnum:]]*_)(?# the word isn\'t in all caps and doesn\'t contain underscores))(?:[a-z0-9]*)))|(\G(?\'trailing_word\'[A-Z][a-z0-9]*))/m';
$str = 'PascalCase
Pascal
PascalCaseCase
Pascal684Case
Pas45calCase
PascalCase6523Case
PascalCaseCaseCase
PPascal
PascalCCase
camelCase
// some random commentary with Capitalized and SCREAMING letters
SCREAMING_SNAKE_CASE
Pascal_Snake_Case
';
$subst = "\L${first_word}${trailing_word:+_\L${trailing_word}:}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;