re = /^ksn-(?:a-(?:stat|p2p)|file|verdict|url|c?info)-geo\.kaspersky-labs\.com$/mi
str = 'ksn-a-stat-geo.kaspersky-labs.com
ksn-a-p2p-geo.kaspersky-labs.com
ksn-file-geo.kaspersky-labs.com
ksn-verdict-geo.kaspersky-labs.com
ksn-url-geo.kaspersky-labs.com
ksn-info-geo.kaspersky-labs.com
ksn-cinfo-geo.kaspersky-labs.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end