# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^ksn-(?:a-(?:stat|p2p)|file|verdict|url|c?info)-geo\.kaspersky-labs\.com$"
test_str = ("ksn-a-stat-geo.kaspersky-labs.com\n"
"ksn-a-p2p-geo.kaspersky-labs.com\n"
"ksn-file-geo.kaspersky-labs.com\n"
"ksn-verdict-geo.kaspersky-labs.com\n"
"ksn-url-geo.kaspersky-labs.com\n"
"ksn-info-geo.kaspersky-labs.com\n"
"ksn-cinfo-geo.kaspersky-labs.com\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.