using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ksn-(?:a-(?:stat|p2p)|file|verdict|url|c?info)-geo\.kaspersky-labs\.com$";
string input = @"ksn-a-stat-geo.kaspersky-labs.com
ksn-a-p2p-geo.kaspersky-labs.com
ksn-file-geo.kaspersky-labs.com
ksn-verdict-geo.kaspersky-labs.com
ksn-url-geo.kaspersky-labs.com
ksn-info-geo.kaspersky-labs.com
ksn-cinfo-geo.kaspersky-labs.com
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}