package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^ksn-(?:a-(?:stat|p2p)|file|verdict|url|c?info)-geo\.kaspersky-labs\.com$`)
var str = `ksn-a-stat-geo.kaspersky-labs.com
ksn-a-p2p-geo.kaspersky-labs.com
ksn-file-geo.kaspersky-labs.com
ksn-verdict-geo.kaspersky-labs.com
ksn-url-geo.kaspersky-labs.com
ksn-info-geo.kaspersky-labs.com
ksn-cinfo-geo.kaspersky-labs.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}