$re = '/\+?(1?)[\(\s]*([2-9]\d{2})[\s\)]*(\d{3})[\s-]*(\d{4})/';
$str = '12345678900
514 706 0306
514 706-0306
(514) 706-0306
+1 514 7090306
15147060306';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);