const regex = /\+?(1?)[\(\s]*([2-9]\d{2})[\s\)]*(\d{3})[\s-]*(\d{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+?(1?)[\\(\\s]*([2-9]\\d{2})[\\s\\)]*(\\d{3})[\\s-]*(\\d{4})', 'g')
const str = `12345678900
514 706 0306
514 706-0306
(514) 706-0306
+1 514 7090306
15147060306`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}