import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+?(1?)[\\(\\s]*([2-9]\\d{2})[\\s\\)]*(\\d{3})[\\s-]*(\\d{4})";
final String string = "12345678900\n"
+ "514 706 0306\n"
+ "514 706-0306\n"
+ "(514) 706-0306\n"
+ "+1 514 7090306\n"
+ "15147060306";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}