package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\+?(1?)[\(\s]*([2-9]\d{2})[\s\)]*(\d{3})[\s-]*(\d{4})`)
var str = `12345678900
514 706 0306
514 706-0306
(514) 706-0306
+1 514 7090306
15147060306`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}