import Foundation
let pattern = #"^(http|https):\/\/[\d\w]{1,64}\.?[\d\w]{2,15}(\/[\d\w]*)*\??[\d\w&=]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"http://localhost.com/test/asSf?test=est&test"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}