package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^(http|https):\/\/[\d\w]{1,64}\.?[\d\w]{2,15}(\/[\d\w]*)*\??[\d\w&=]*$`)
var str = `http://localhost.com/test/asSf?test=est&test`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}