using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(http|https):\/\/[\d\w]{1,64}\.?[\d\w]{2,15}(\/[\d\w]*)*\??[\d\w&=]*$";
string input = @"http://localhost.com/test/asSf?test=est&test";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}