const regex = /^(http|https):\/\/[\d\w]{1,64}\.?[\d\w]{2,15}(\/[\d\w]*)*\??[\d\w&=]*$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(http|https):\\\/\\\/[\\d\\w]{1,64}\\.?[\\d\\w]{2,15}(\\\/[\\d\\w]*)*\\??[\\d\\w&=]*$', 'i')
const str = `http://localhost.com/test/asSf?test=est&test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}