const regex = new RegExp('(fprintf(\\s*)\\((\\s*\\S+\\s*)[,])([^\\"])', 'gm')
const str = `fprintf ( out , os.str().c_str());`;
const subst = `\1 "%s",`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);