using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(fprintf(\s*)\((\s*\S+\s*)[,])([^\""])";
string substitution = @"\1 ""%s"",";
string input = @"fprintf ( out , os.str().c_str());";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}