# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(fprintf(\s*)\((\s*\S+\s*)[,])([^\"])/\1 "%s",/gm;t' <<< "fprintf ( out , os.str().c_str());"