package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(fprintf(\s*)\((\s*\S+\s*)[,])([^\"])`)
var str = `fprintf ( out , os.str().c_str());`
var substitution = "\1 "%s","
fmt.Println(re.ReplaceAllString(str, substitution))
}