import Foundation
let pattern = #"^PATS_TEST,\s*[0-9A-Za-z_.]{1,50},\d+\/\d+\/\d+\s+\d+[:.]\d+[:.]\d+,[^,]+,[^,]*,[^,]*,[^,]*,[PFAI],[^,]*,[^,]*,[^,]*,[^,]*,[^,]*,[^,]*,[^,]*,[^,]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
PATS_TEST,24151N073332,04/07/2016.09.53.45,TEST_START_TIME, ,4/7/2016 9:46:02 AM, ,PASS, ,15,NONE,0.01,0,, ,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}