using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^PATS_TEST,\s*[0-9A-Za-z_.]{1,50},\d+\/\d+\/\d+\s+\d+[:.]\d+[:.]\d+,[^,]+,[^,]*,[^,]*,[^,]*,[PFAI],[^,]*,[^,]*,[^,]*,[^,]*,[^,]*,[^,]*,[^,]*,[^,]*$";
string input = @"
PATS_TEST,24151N073332,04/07/2016.09.53.45,TEST_START_TIME, ,4/7/2016 9:46:02 AM, ,PASS, ,15,NONE,0.01,0,, ,
";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}