package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^PATS_TEST,\s*[0-9A-Za-z_.]{1,50},\d+\/\d+\/\d+\s+\d+[:.]\d+[:.]\d+,[^,]+,[^,]*,[^,]*,[^,]*,[PFAI],[^,]*,[^,]*,[^,]*,[^,]*,[^,]*,[^,]*,[^,]*,[^,]*$`)
var str = `
PATS_TEST,24151N073332,04/07/2016.09.53.45,TEST_START_TIME, ,4/7/2016 9:46:02 AM, ,PASS, ,15,NONE,0.01,0,, ,
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}