re = /\[DE\](.*?)\[\/DE\]/
str = '[DE]lkjhkjh
huhu[/DE]
[EN]
lkjlkjlkjlkjhkhj
sjdkjdhfksjfhsdkshkjhf
sfksjdksjfkdsfksjdfh
skjfkjskfjdsfh
dsjfhskjfdkjsfhd
[/EN]
[DE]
lsdkflkdsj
kjlskdjfldj
kjlskdjlksfdljs
flkslfkslfsdkfldsfdskfljdsk
lksjdlkslfdkslfsdfkjfs
jkjhkjkjhkjh
lkjlkljjlkjklj
[/DE]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end