$re = '/\[DE\](.*?)\[\/DE\]/s';
$str = '[DE]lkjhkjh
huhu[/DE]
[EN]
lkjlkjlkjlkjhkhj
sjdkjdhfksjfhsdkshkjhf
sfksjdksjfkdsfksjdfh
skjfkjskfjdsfh
dsjfhskjfdkjsfhd
[/EN]
[DE]
lsdkflkdsj
kjlskdjfldj
kjlskdjlksfdljs
flkslfkslfsdkfldsfdskfljdsk
lksjdlkslfdkslfsdfkjfs
jkjhkjkjhkjh
lkjlkljjlkjklj
[/DE]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);