import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[DE\\](.*?)\\[\\/DE\\]";
final String string = "[DE]lkjhkjh\n\n"
+ "huhu[/DE]\n\n"
+ "[EN]\n"
+ "lkjlkjlkjlkjhkhj\n"
+ "sjdkjdhfksjfhsdkshkjhf\n"
+ "sfksjdksjfkdsfksjdfh\n"
+ "skjfkjskfjdsfh\n"
+ "dsjfhskjfdkjsfhd\n\n"
+ "[/EN]\n\n"
+ "[DE]\n"
+ "lsdkflkdsj\n"
+ "kjlskdjfldj\n"
+ "kjlskdjlksfdljs\n"
+ "flkslfkslfsdkfldsfdskfljdsk\n"
+ "lksjdlkslfdkslfsdfkjfs\n"
+ "jkjhkjkjhkjh\n"
+ "lkjlkljjlkjklj\n"
+ "[/DE]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}