package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\[DE\](.*?)\[\/DE\]`)
var str = `[DE]lkjhkjh
huhu[/DE]
[EN]
lkjlkjlkjlkjhkhj
sjdkjdhfksjfhsdkshkjhf
sfksjdksjfkdsfksjdfh
skjfkjskfjdsfh
dsjfhskjfdkjsfhd
[/EN]
[DE]
lsdkflkdsj
kjlskdjfldj
kjlskdjlksfdljs
flkslfkslfsdkfldsfdskfljdsk
lksjdlkslfdkslfsdfkjfs
jkjhkjkjhkjh
lkjlkljjlkjklj
[/DE]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}