# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(([0-9]|10)|([0-9][.,][0]?[1-9][1-9]?))$"
test_str = ("0\n"
"5\n"
"10\n"
"0.5\n"
"0.25\n"
"5.75\n"
"3.03\n\n"
"5.0\n"
"3.333\n"
"11\n"
"20\n"
"05\n"
"10.5\n"
"3.30\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.