using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([0-9]|10)|([0-9][.,][0]?[1-9][1-9]?))$";
string input = @"0
5
10
0.5
0.25
5.75
3.03
5.0
3.333
11
20
05
10.5
3.30
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}