#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([0-9]|10)|([0-9][.,][0]?[1-9][1-9]?))$"
Local $sString = "0" & @CRLF & _
"5" & @CRLF & _
"10" & @CRLF & _
"0.5" & @CRLF & _
"0.25" & @CRLF & _
"5.75" & @CRLF & _
"3.03" & @CRLF & _
"" & @CRLF & _
"5.0" & @CRLF & _
"3.333" & @CRLF & _
"11" & @CRLF & _
"20" & @CRLF & _
"05" & @CRLF & _
"10.5" & @CRLF & _
"3.30" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")