const regex = /^(([0-9]|10)|([0-9][.,][0]?[1-9][1-9]?))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([0-9]|10)|([0-9][.,][0]?[1-9][1-9]?))$', 'gm')
const str = `0
5
10
0.5
0.25
5.75
3.03
5.0
3.333
11
20
05
10.5
3.30
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}