import Foundation
let pattern = #"\{\$[a-zA-Z0-9._+%]+\}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Obsahová symbolika
{$nadpish21} - nadpis h1 - h6, 1 - 128
{$htmltext21} - html text 1 - 128
{$plaintext1} - čistý text 1 - 128
{$arturl} - url daného konkrétního článku
{$pageurl1} - url vybraného článku, 1 - 128
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}