// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\{\$[a-zA-Z0-9._+%]+\}").unwrap();
let string = "Obsahová symbolika
{$nadpish21} - nadpis h1 - h6, 1 - 128
{$htmltext21} - html text 1 - 128
{$plaintext1} - čistý text 1 - 128
{$arturl} - url daného konkrétního článku
{$pageurl1} - url vybraného článku, 1 - 128";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}