import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\$[a-zA-Z0-9._+%]+\\}";
final String string = "Obsahová symbolika\n\n"
+ "{$nadpish21} - nadpis h1 - h6, 1 - 128\n"
+ "{$htmltext21} - html text 1 - 128\n"
+ "{$plaintext1} - čistý text 1 - 128\n"
+ "{$arturl} - url daného konkrétního článku\n"
+ "{$pageurl1} - url vybraného článku, 1 - 128";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}