re = /\{\$[a-zA-Z0-9._+%]+\}/
str = 'Obsahová symbolika
{$nadpish21} - nadpis h1 - h6, 1 - 128
{$htmltext21} - html text 1 - 128
{$plaintext1} - čistý text 1 - 128
{$arturl} - url daného konkrétního článku
{$pageurl1} - url vybraného článku, 1 - 128'
# Print the match result
str.match(re) do |match|
puts match.to_s
end