re = /(?<cond>\{(\$|if|foreach).+\})(.|\n)?(\{end\k<cond>|)/m
str = '{if $var == 0}
text
{endif}
{foreach $array as $key => $val}
{if $var == 1}{endif}
{endforeach}
{$var}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end