import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<cond>\\{(\\$|if|foreach).+\\})(.|\\n)?(\\{end\\k<cond>|)";
final String string = "{if $var == 0}\n"
+ "text\n"
+ "{endif}\n\n"
+ "{foreach $array as $key => $val}\n"
+ " {if $var == 1}{endif}\n"
+ "{endforeach}\n\n"
+ "{$var}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}