#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<cond>\{(\$|if|foreach).+\})(.|\n)?(\{end\k<cond>|)"
Local $sString = "{if $var == 0}" & @CRLF & _
"text" & @CRLF & _
"{endif}" & @CRLF & _
"" & @CRLF & _
"{foreach $array as $key => $val}" & @CRLF & _
" {if $var == 1}{endif}" & @CRLF & _
"{endforeach}" & @CRLF & _
"" & @CRLF & _
"{$var}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")