$re = '/(?<cond>\{(\$|if|foreach).+\})(.|\n)?(\{end\k<cond>|)/m';
$str = '{if $var == 0}
text
{endif}
{foreach $array as $key => $val}
{if $var == 1}{endif}
{endforeach}
{$var}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);