use strict;
my $str = ' RIH W/17 1/2" NEW M.T BIT, 9 1/2" SH.SUB & 9 1/2" MONEL, TAG BTM @ 45\'
N/U 13 5/8"-5K X 11"-10 K PSI CIW C.H.SPOOL
OFF BTN / ON BTM TQ: 5 - 6 / 10 -16 KLB.FT.';
my $regex = qr/(?:\d+\s*[\s+|\-+]\s*\d+\s*\/\s*\d+(?!\d*\s*\-))/mp;
my $subst = ', ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";