using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\d+\s*[\s+|\-+]\s*\d+\s*\/\s*\d+(?!\d*\s*\-))";
string substitution = @", ";
string input = @" RIH W/17 1/2"" NEW M.T BIT, 9 1/2"" SH.SUB & 9 1/2"" MONEL, TAG BTM @ 45'
N/U 13 5/8""-5K X 11""-10 K PSI CIW C.H.SPOOL
OFF BTN / ON BTM TQ: 5 - 6 / 10 -16 KLB.FT.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}