re = /^(?=^abc)(?=.*123)(?=.*xyz$)/
str = '#starts with abc, has 123 and ends with xyz
abc123xyz'
# Print the match result
str.match(re) do |match|
puts match.to_s
end