using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=^abc)(?=.*123)(?=.*xyz$)";
string input = @"#starts with abc, has 123 and ends with xyz
abc123xyz";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}