const regex = /^(?=^abc)(?=.*123)(?=.*xyz$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=^abc)(?=.*123)(?=.*xyz$)', '')
const str = `#starts with abc, has 123 and ends with xyz
abc123xyz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}