$re = '/^(?=^abc)(?=.*123)(?=.*xyz$)/';
$str = '#starts with abc, has 123 and ends with xyz
abc123xyz';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);