re = /^\s*function\s+([a-zA-Z$_][a-zA-Z\d$_]*)\s*\(/
str = '
function
$$
(z) {
if (z == true) {
console.log ("Something says Z is true");
}
}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end