#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\s*function\s+([a-zA-Z$_][a-zA-Z\d$_]*)\s*\("
Local $sString = "" & @CRLF & _
" function" & @CRLF & _
" " & @CRLF & _
" $$ " & @CRLF & _
"(z) {" & @CRLF & _
" if (z == true) {" & @CRLF & _
" console.log ("Something says Z is true");" & @CRLF & _
" }" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")