import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*function\\s+([a-zA-Z$_][a-zA-Z\\d$_]*)\\s*\\(";
final String string = "\n"
+ " function\n"
+ " \n"
+ " $$ \n"
+ "(z) {\n"
+ " if (z == true) {\n"
+ " console.log (\"Something says Z is true\");\n"
+ " }\n"
+ " }";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}